FANDOM


Game DependenciesEdit

Before running Trosnoth from the source distribution, you will need to install the following dependencies:

Under Debian or Ubuntu, you can install these dependencies by typing:

sudo apt-get install python2.7 python-pygame python-twisted

Under Fedora, CentOS or RHEL, type:

sudo yum install python pygame python-twisted

If these instructions don't work for your favourite OS, follow the links above to download and install the libraries.

Getting the SourceEdit

You can download the latest source distribution from trosnoth.org. To install the game, simply unzip the game, navigate to the unzipped game, and type:

python setup.py install

After this, you should be able to run the game from a shell window by typing "trosnoth". If you want desktop / menu shortcuts, you'll have to set them up yourself.

Old VersionsEdit

See Trosnoth on PyPI for old source distributions.

Ad blocker interference detected!


Wikia is a free-to-use site that makes money from advertising. We have a modified experience for viewers using ad blockers

Wikia is not accessible if you’ve made further modifications. Remove the custom ad blocker rule(s) and the page will load as expected.